Unstable Intercom Connection Despite Stable Network (Ping OK)

Symptoms

The intercom device status continuously changes between "Available" and "Disconnected" even though the device is reachable on the network.

Related symptoms

Details

This issue can be recognized by observing the device status in the system:

Even though the network connection appears stable (for example, ping tests are successful), the intercom is not consistently available for calls.

Cause

Short registration timeout

The configured registration timeout of the PBX device is too low.

This means:

Network Issue

Even when ping appears stable, there can still be network issues such as:

Solution(s)

Increase Registration Timeout

1. Open the PBX device configuration

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2. Locate the registration timeout setting

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3. Increase the timeout value (for example: use a higher and stable value)

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4. Save the configuration

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Add rule for outbound SIP traffic

When no outbound rule for SIP traffic is configured the server can only accept registrations and not monitor them.

This may cause unstable registration status for certain intercom devices.

Effects:

Asterisk Connector Version: 5.4.3 and lower

CoCoS Version: 5.1.0 and onwards.

Note: You will need access to system / networkFirewall to manage firewall rules.

1. Navigate to: System  Network → Firewall

2. Create a new rule with:

  • Direction: OUTPUT
  • Protocol: UDP
  • Destination port: 5060

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3. Click Save and Close to store the rule configuration.


References


Revision #5
Created 2026-04-23 10:28:13 UTC by Rick
Updated 2026-05-12 13:25:30 UTC by Rick