# Unstable Intercom Connection Despite Stable Network (Ping OK)

## Symptoms

The intercom device status continuously changes between **"Available"** and **"Disconnected"** even though the device is reachable on the network.

#### Related symptoms

- Intercom registration appears unstable
- Intercom goes offline and online repeatedly
- Device shows as disconnected while ping remains stable
- Calls to the intercom sometimes fail ( during connection losses )
- Error message when calling the intercom:  
    *"Could not initiate call because the destination is not available for calls"*

#### Details

This issue can be recognized by observing the device status in the system:

- The intercom successfully registers initially
- After a short time, the device status changes to **Disconnected**
- Shortly after, the device registers again and becomes **Available**
- This cycle repeats continuously

Even though the network connection appears stable (for example, ping tests are successful), the intercom is not consistently available for calls.

## Cause

#### Short registration timeout

The configured registration timeout of the PBX device is too low.

This means:

- The registration expires before the intercom renews it
- The system temporarily marks the device as **Disconnected**
- The intercom then re-registers, causing the status to switch back to **Available**

#### Network Issue

Even when ping appears stable, there can still be network issues such as:

- Packet loss
- Delayed responses
- NAT session timeouts
- Firewall (mis)configuration

## Solution(s)

### Increase Registration Timeout

<table border="1" id="bkmrk-1.-open-the-pbx-devi" style="border-collapse: collapse; width: 100%; height: 598.376px;"><colgroup><col style="width: 50%;"></col><col style="width: 50%;"></col></colgroup><tbody><tr style="height: 202.148px;"><td style="height: 202.148px;">**1.** Open the PBX device configuration</td><td style="height: 202.148px;">[![image.png](https://knowledgebase.cocos.software/uploads/images/gallery/2026-04/scaled-1680-/GFxWLlT5MDnSGysT-image.png)](https://knowledgebase.cocos.software/uploads/images/gallery/2026-04/GFxWLlT5MDnSGysT-image.png)

</td></tr><tr style="height: 200.08px;"><td style="height: 200.08px;">**2.** Locate the registration timeout setting</td><td style="height: 200.08px;">[![image.png](https://knowledgebase.cocos.software/uploads/images/gallery/2026-04/scaled-1680-/Re7Z7ObA7zvecUaH-image.png)](https://knowledgebase.cocos.software/uploads/images/gallery/2026-04/Re7Z7ObA7zvecUaH-image.png)

</td></tr><tr style="height: 166.625px;"><td style="height: 166.625px;">**3.** Increase the timeout value (for example: use a higher and stable value)</td><td style="height: 166.625px;">[![image.png](https://knowledgebase.cocos.software/uploads/images/gallery/2026-04/scaled-1680-/vYSEdqFpietXIDP0-image.png)](https://knowledgebase.cocos.software/uploads/images/gallery/2026-04/vYSEdqFpietXIDP0-image.png)

</td></tr><tr style="height: 29.5227px;"><td style="height: 29.5227px;">**4.** Save the configuration</td><td style="height: 29.5227px;">[![image.png](https://knowledgebase.cocos.software/uploads/images/gallery/2026-04/scaled-1680-/f2WuV5HqGCgJoxcV-image.png)](https://knowledgebase.cocos.software/uploads/images/gallery/2026-04/f2WuV5HqGCgJoxcV-image.png)

</td></tr></tbody></table>

### Add rule for outbound SIP traffic

When no outbound rule for SIP traffic is configured the server can only accept registrations and not monitor them.

This may cause unstable registration status for certain intercom devices.

**Effects:**

Asterisk Connector Version: 5.4.3 and lower

CoCoS Version: 5.1.0 and onwards.

<p class="callout info">Note: You will need access to system / networkFirewall to manage firewall rules.</p>

<table border="1" id="bkmrk-1.-navigate-to%3A-syst" style="border-collapse: collapse; width: 100%;"><colgroup><col style="width: 50%;"></col><col style="width: 50%;"></col></colgroup><tbody><tr><td>**1.** Navigate to: **System** **→** **Network → Firewall**</td><td>  
</td></tr><tr><td>**2.** Create a new rule with:

- Direction: OUTPUT
- Protocol: UDP
- Destination port: 5060

</td><td>[![image.png](https://knowledgebase.cocos.software/uploads/images/gallery/2026-05/scaled-1680-/0UJN5SZFwmuGmZge-image.png)](https://knowledgebase.cocos.software/uploads/images/gallery/2026-05/0UJN5SZFwmuGmZge-image.png)

</td></tr><tr><td>**3.** Click **Save and Close** to store the rule configuration.

</td><td>  
</td></tr></tbody></table>

## References

- [Start packet trace in CoCoS](https://knowledgebase.cocos.software/books/cocos/page/how-to-start-a-packet-capture)
- [Intercom not registering](https://knowledgebase.cocos.software/books/cocos/page/intercom-not-registering-device-not-available)