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Verifying DTMF Output Switching Functionality

Symptomes

The issue occurs when using a DTMF action to switch outputs (for switching doors, barriers, etc.) during a call. The expected output switching does not happen, or it happens inconsistently.

The output switch may fail if the intercoms are unavailable or busy, the called number is blacklisted, the specific action (calling a script, setting a tag, etc.) configured to be executed after the DTMF action may have failed, and/or network instability may also contribute to the problem.

How to Reproduce

(Optional section)

Stap 1: 
Open the CoCoS Logging

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Stap 1: 
Open Open a logbook item

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Application

(Optional section)

Describe in which application / in what way the problem occurred. The issue was noticed when a script was created to open a door using an IO device controlled by webhooks.

Cause

Issues with DTMF actions are likely caused by one or more of the following:

  • Intercom unavailability: If the intercom(s) involved in the action are unavailable or busy, the output switching may not occur since a call from this intercom can not be made.

  • Called number is blacklisted: If an allow list is specified for the DTMF action, the called number may not be allowed to preform the action when they press the DTMF digit.
  • Script, tag, or other action failed: If an action is configured for the DTMF action, this action may have failed.

Solution / How To

  1. Check the call history: Verify that calls are being started from intercom(s), and are successfull.
  2. Check the call logs: Open one or more of the calls to check the logs for any issues, and open the value history to check if the required DTMF digit was send by the called party / caller. (See also article ...)
  3. Monitor the intercom status: See article ...
  4. Check the configured action: 
    1. For script action check article ...
    2. For tag action check article ...

References

Describe where to find external answers or extra informations