Verifying DTMF Output Switching Functionality
Symptomes
The issue occurs when using a DTMF action to switch outputs (for switching doors, barriers, etc.) during a call. The expected output switching does not happen, or it happens inconsistently.
The output switch may fail if the intercoms are unavailable or busy, the called number is blacklisted, the specific action (calling a script, setting a tag, etc.) configured to be executed after the DTMF action may have failed, and/or network instability may also contribute to the problem.
How to Reproduce
(Optional section)
Go |
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Enter |
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During the conversation press the DTMF digit that should preform the configured action. |
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The configured DTMF action should now be executed. |
Application
(Optional section)
Describe in which application / in what way the problem occurred. The issue was noticed when a script was created to open a door using an IO device controlled by webhooks.
Cause
Issues with DTMF actions are likely caused by one or more of the following:
Solution / How To
- Check the call
history:historyVerifythatNavigate to "Intercom / Call History" Here you can see a list of all calls
are being started from intercom(s), and are successfull.Checkon thecallsystem.logs:If your issue is with a specific intercom or location, you might want to filter on this specific location or intercom (number).
Open one
or moreof the callstowherecheckyou might suspect thelogsissueforisanypresent.
Inissues,thisand opencase thevalueconfiguredhistoryDTMF does not work when calling a specific number.First to check if the
requiredDTMFdigitaction was send by the calledpartynumber/wecaller.will(See also article ...)Monitoropen theintercomvaluestatus:historySeeandarticlesearch for a message like the following: "event(press).digit(1)"When this message is not present, this would mean that the user (the called number) did not press a DTMF digit during the call, or the DTMF was pressed but not received due to a network issue.
After that we will check the logbook for any logs that would indicate an issue.
In this case I was able to find a log message that indicated that the DTMF action was denied for the called number
(meaning the called number was not found in the configured allow list for the DTMF action).
.2. Check the configured
action:actionReferences
Describe where to find external answers or extra informations










