Verifying Trigger Functionality
Symptoms
Triggers are used to automate actions like opening a door or sending a notification — when they don’t work, it’s often due to incorrect conditions or misconfigurations.
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A trigger does not activate even when the expected conditions are met.
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No expected action (e.g., door opening, message sending) occurs when a trigger action is executed (like a script).
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Logs or UI show no sign that a trigger has fired.
 
Cause
Issues with triggers are likely caused by one or more of the following:
- The trigger condition does not match the actual situation.
 - The trigger condition is misconfigured.
 - The trigger action is misconfigured.
 
Solution / How To
Use the steps below to identify and resolve the issue.
1. Check if the trigger has executed
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 Go to the item your trigger is attached to (e.g., a tag). 
 Open the Triggers tab. 
 Look for the trigger in the list. 
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 Here you should see that the trigger was executed. 
 
 Confirm that the trigger has been executed. If not, refer to the appropriate article based on trigger condition: 
 
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2. Verify the trigger condition
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 When the trigger was not executed, ensure that the condition is actually being met. 
 If it's based on a tag value or state, double-check that the tag is updating correctly 
 For help verifying tags, see: Verifying Tag Functionality  | 
3. Check the configured action
| Open the trigger and go to the Action section. | |
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 Verify that the correct action type is selected, and confirm that all required fields are properly filled in. 
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 To verify that the specified action functions correctly, check one of the following articles: 
 
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