Skip to main content

CoCoS Client requires login

Symptoms

A CoCoS Client isn't booting/is stuck on the login screen after boot.

Related symptoms

  • CoCoS client login screen

  • CoCoS client not starting application
  • How to login to CoCoS client at login screen.

Details

The issue can be recognized when, after a reboot, the system doesn't automatically log in, but it is stuck on the login screen instead and asks for a password to log in/continue, like in the example image below:

afbeelding.png

Cause

This issue might be caused by a full disk. When the disk is full, the system doesn't boot properly anymore. Also, additional services like TeamViewer, AnyDesk or VNC won't be started, and therefore, the system is completely out of reach. SSH might be the only option to log in to the system remotely.

Solution for experienced users.

Step 1

Login to the CoCoS Management and check the following 



Step 2


Check the logbook for issues with descriptions for solutions. Open the device that is not starting properly.

 

Step 3


If no error is availble with an suitable solution, please restart the CoCoS client using the reboot option in the CoCoS management. On a reboot the system will clean up data and settings where possible.


 

 

Step 4


Hard reboot the system (power cycle) if the above steps dit not offer a solution. 

 


Step 5


If a reboot fails, does not solve the issue, or the issue reappears after some time, please contact your CoCoS support contact with a detailed description, timestamps of the occurrence and preferably a picture of the error. Please also include a link to this article as a description of the issue.

 



Solution for experts

Log in to the CoCoS Client using SSH, for example, using PuTTY.


Use the command below to check if the disk is full. If so, continue with the next step.

df -h

In the example image, we'll see there are 0 bytes/there's 100% in use, indicating the disk is full.

image.png

Use the command below to find out which directory takes up the most space.

du -h / | grep -E "[0-9]G"

In the example image, we can see that the directory "/home/pi/.config/chromium/Default/Extensions/cjpalhdlnbpafiamejdnhcphjbkeiagm" is occupying too much space.

This is caused by the "uBlock Origin" extension in the Chromium browser, which is sometimes pre-installed on the Raspberry Pi OS Desktop version.

 

Other folders that can take up a lot of space can sometimes be located in /var/log or /var/log/journal.

 

image.png

Remove the files or/directories taking up a lot of disk space. See the commands below for example.

For a directory:

 

rm -Rf /home/pi/.config/chromium/Default/Extensions/cjpalhdlnbpafiamejdnhcphjbkeiagm

For a file:

 

rm /var/log/syslog

Optionally, find out why the disk space got full and/or if any fixes are available to prevent this.

 


References